Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Guide: Using ProxHTTPSProxy on Windows XP/Vista to avoid messenger errors
When using Windows XP or Windows Vista, you will encounter that its TLS support is not so compatible with the modern today of the Internet, considering TLS 1.0 & TLS 1.1 is now being deprecated. That's where this proxy comes in handy! Note you must have the latest Service Pack and latest supported Internet Explorer version in order to this to work like it should. On Windows XP x86 you can optionally enable the POSReady 2009 registry trick to update your system until April 2019. Anyways, let's start!

First download the Proxy and install it. Open "(Your drive letter)/Program Files/ProxHTTPSProxy" folder and double click on ProxHTTPS Cert Install.exe wait a few seconds and after open ProxySwitch.bat", press A. Now that you activated it open ProxHTTPSProxy_PSwitch.exe and wait a few seconds, when a Windows Firewall warning comes up click Unblock.

Chrome/Chromium based browser users

Your all done, But there has been reported that users are unable to use Discord on Chromium-based browser or Ripcord on Windows Vista as it's stuck at the connecting window. To fix this, Open config.ini file and below [SSL Pass-Thru] add:


Firefox based browser users

To avoid getting certificate errors due to the proxy, open Preferences > Advanced > Connection Settings and uncheck No Proxy


Optional Components

Cert Updater v1.6 can be used to update root certificates under Windows XP/Vista, as the one bundled on these OSes by default, no longer works after End-Of-Support.

TrayIt! is useful to completely minimize to tray programs who can't do by design.

Of course you can delete either the proxy or TrayIt! from the startup folder if desired

And last I would like to thank Heinoganda for his proxy.

Well, that's it for now  Big Grin
thats an nice guide also tnx for mentioning trayit
Great guide. For some reason, all of this only worked if I ran "ProxySwitch.bat" manually with the A argument, because pressing while it was open didn't work.

Forum Jump:

Users browsing this thread: 1 Guest(s)